Tagged with #maxinsertsizefilter
0 documentation articles | 0 announcements | 1 forum discussion

No articles to display.

No articles to display.

Created 2013-03-13 13:07:04 | Updated 2013-03-13 13:09:48 | Tags: maxinsertsizefilter

Comments (5)

Hi Is it possible to set the maximum insert size allowed for the MaxInsertSize read filter? Looking at the documentation at http://www.broadinstitute.org/gatk/gatkdocs/org_broadinstitute_sting_gatk_filters_MaxInsertSizeFilter.html it's set with a default value of 1,000,000 which is too high for what we want.

If it is possible how does one set it I've tried several different combinations and nothing seems to work, apart from leaving it with it's default value. Reading the doc it looks like --maxInsertSize 1000 should work, but GATK refuses to accept that complaining the 1000 is an unknown argument.

I've tried -rf MaxInsertSize GATK runs with that as long as I don't try to supply a number to adjust the default value. So -rf MaxInsertSize 1000, -rf MaxInsertSize=1000,-maxInsertSize=1000,-maxInsertSize 1000 etc don't work though looking at the docs I would have thought at least one of them would have.