Tagged with #failure
0 documentation articles | 0 announcements | 2 forum discussions


No posts found with the requested search criteria.
No posts found with the requested search criteria.

Created 2016-01-20 16:11:48 | Updated | Tags: install picard failure htsjdk
Comments (10)

(If this is the wrong place to post this, please tell me where to go)

I am new to GATK, trying to build Picard because I apparently will need to build Picard sequence directories for my genomes of interest.

I have installed Java6, Java8, ant, and HTSJDK. I have downloaded Picard 2a49ee2.

Following instructions at broadinstitute.github.io/picard/building.html, I have defined JAVA6_HOME, cd'd into broadinstitute-picard-2a49ee2, and when I run ant -lib lib/ant package-commands I get this message (relevant part only) "BUILD FAILED ... Basedir .../broadinstitute-picard-2a49ee2/htsjdk does not exist"

So it seems I need to do something for the build to know where my HTSJDK lives. Or did my download fail? Am I supposed to make a symbolic link from .../broadinstitute-picard-2a49ee2/htsjdk over to someplace in my HTSJDK directory? If so, to where?

Thanks for any help, Bob H


Created 2013-02-15 09:23:37 | Updated | Tags: blip failure tmp
Comments (17)

When trying to run the UnifiedGenotyper, I keep getting the following

ERROR MESSAGE: There was a failure because temporary file /tmp/org.broadinstitute.sting.gatk.io.stubs.VariantContextWriterStub7040175770023361502.tmp could not be found while running the GATK with more than one thread. Possible causes for this problem include: your system's open file handle limit is too small, your output or temp directories do not have sufficient space, or just an isolated file system blip

About the suggested causes:

  • The system's open file handle limit is set to 4827982, I doubt that this is exhausted.
  • On the /tmp/ file system, there is 200GB of free space; each GATK run seems to use less that 1/1000 of that.
  • I have no idea what a file system blip would be, but apparently it occurs every time I run the UnifiedGenotyper. Any idea why this would be, and how it could be avoided?

Or could there be still a different reason for the error?

Thanks, Alex