UnifiedGenotyper gives empty vcf file on exampleBAM.bam
Posted in Ask the GATK team | Last updated on 2013-10-26 06:03:06


Comments (3)

Hi, I‘m trying UnifiedGenotyper on the exampleBAM.bam in source/ , but it generated empty vcf files. Here's my command:

java -jar GenomeAnalysisTK.jar -T UnifiedGenotyper -R exampleFASTA.fasta -I exampleBAM.bam -o test.vcf -stand_emit_conf 10.0

Gives me this output:

INFO 00:02:40,348 HelpFormatter - --------------------------------------------------------------------------------

INFO 00:02:40,354 HelpFormatter - The Genome Analysis Toolkit (GATK) v2.7-4-g6f46d11, Compiled 2013/10/10 17:27:51

INFO 00:02:40,354 HelpFormatter - Copyright (c) 2010 The Broad Institute

INFO 00:02:40,355 HelpFormatter - For support and documentation go to http://www.broadinstitute.org/gatk

INFO 00:02:40,361 HelpFormatter - Program Args: -T UnifiedGenotyper -R exampleFASTA.fasta -I exampleBAM.bam --o test.vcf -stand_emit_conf 10.0

INFO 00:02:40,362 HelpFormatter - Date/Time: 2013/10/26 00:02:40

INFO 00:02:40,362 HelpFormatter - --------------------------------------------------------------------------------

INFO 00:02:40,362 HelpFormatter - --------------------------------------------------------------------------------

INFO 00:02:42,599 GenomeAnalysisEngine - Strictness is SILENT

INFO 00:02:43,102 GenomeAnalysisEngine - Downsampling Settings: Method: BY_SAMPLE, Target Coverage: 250

INFO 00:02:43,115 SAMDataSource$SAMReaders - Initializing SAMRecords in serial

INFO 00:02:43,162 SAMDataSource$SAMReaders - Done initializing BAM readers: total time 0.05

INFO 00:02:43,559 GenomeAnalysisEngine - Preparing for traversal over 1 BAM files

INFO 00:02:43,598 GenomeAnalysisEngine - Done preparing for traversal

INFO 00:02:43,598 ProgressMeter - [INITIALIZATION COMPLETE; STARTING PROCESSING]

INFO 00:02:43,598 ProgressMeter - Location processed.sites runtime per.1M.sites completed total.runtime remaining

INFO 00:02:53,993 ProgressMeter - done 1.00e+05 10.0 s 103.0 s 99.9% 10.0 s 0.0 s

INFO 00:02:53,994 ProgressMeter - Total runtime 10.40 secs, 0.17 min, 0.00 hours

INFO 00:02:53,994 MicroScheduler - 0 reads were filtered out during the traversal out of approximately 33 total reads (0.00%)

INFO 00:02:53,995 MicroScheduler - -> 0 reads (0.00% of total) failing BadMateFilter

INFO 00:02:53,995 MicroScheduler - -> 0 reads (0.00% of total) failing DuplicateReadFilter

INFO 00:02:53,996 MicroScheduler - -> 0 reads (0.00% of total) failing FailsVendorQualityCheckFilter

INFO 00:02:53,996 MicroScheduler - -> 0 reads (0.00% of total) failing MalformedReadFilter

INFO 00:02:53,996 MicroScheduler - -> 0 reads (0.00% of total) failing MappingQualityUnavailableFilter

INFO 00:02:53,997 MicroScheduler - -> 0 reads (0.00% of total) failing NotPrimaryAlignmentFilter

INFO 00:02:53,997 MicroScheduler - -> 0 reads (0.00% of total) failing UnmappedReadFilter

INFO 00:03:06,010 GATKRunReport - Uploaded run statistics report to AWS S3

And the test.vcf is empty with only titles. I have attached this file.

Does anyone see where I made a mistake? Is there another setting which I have to set for finding a SNP in the sample data? Thanks.


Return to top Comment on this article in the forum