GenePattern 3.5 Release Notes  Print-icon

View release notes for all GenePattern versions:
1.0     1.1     1.2     1.2.1     1.3     1.3.1     1.4     1.4.1     2.0     2.0.1     2.0.2     3.0     3.1     3.1.1     3.2     3.2.1     3.2.2     3.2.3     3.3     3.3.2     3.3.3     3.4     3.5     3.6     3.6.1     3.7.0     3.8.0     3.8.1     3.8.2    

Also see the FAQ for more information about new functionality

Released December 2012

GenePattern 3.5 contains several new features and fixes.

New Features

License Support for Modules and Pipelines

GenePattern 3.5 supports the addition of end-user license agreements (EULAs) to modules and pipelines.  Module and pipeline creators can now attach EULA files to new versions of modules or pipelines.  Non-commercial users of these licensed modules/pipelines on either the Broad public server or private GenePattern servers need only accept the license for the version they are using, and their acceptance will be tracked at the Broad.  You need not view/accept EULA terms again unless the module/pipeline is updated.

Commercial users who want to use licensed modules should not accept EULAs that are targeted at academic and non-commercial communities.  In these cases, the licensing text will direct commercial users to contact the GenePattern team at gp-help@broadinstitute.org and request a commercial EULA for the module or pipeline.

Fixes/Enhancements

The 3.5 release fixes issues in GenePattern, including:

Known Issues

Known issues in GenePattern 3.5 include:

1. On the 3.5.0 server, select your pipeline and click edit to open it in the Pipeline Designer.
2. Click Save. You don't need to make any other changes to your pipeline.

1. Move Folder:              Destination: /Library/Frameworks/R.framework/Versions
WARNING - There was a problem copying /Library/Frameworks/R.framework/Versions/2.5

you may need to install R2.5 separately.  Download R2.5 from CRAN and follow the instruction in this section of the Administrators Guide.

Hardware Requirements and Software Compatibility

Hardware requirements: GenePattern's hardware requirements are found on almost all currently available machines:

Supported operating systems: GenePattern installers are available for Windows, Mac OS X, and Linux. GenePattern should work with any operating system that has a Java 5 or 6 virtual machine installed. We have tested it on the following OS platforms:

Supported browsers: GenePattern has been tested on the following browsers:

Current technology versions: Following are the technology versions used in GenePattern 3.5.

Updated on April 17, 2013 11:01