GenePattern 3.4.0 Release Notes

Released September 3, 2012

GenePattern 3.4 contains several new features and fixes.

New Features

New and Improved Module Integrator

The module integrator has been redesigned for ease of use.  Updates include:

  • More intuitive interface
  • Drag-and-drop functionality to reorder parameters
  • Add multiple parameters at once
  • More informative error messages
  • Improved editing of command line arguments
  • Improved adding and deletion of support files

For more information about the new module integrator, see this tutorial.

New and Improved Pipeline Designer

The pipeline designer has been redesigned for ease of use. Updates include:

  • Graphical representation of pipelines
  • Drag-and-drop interface
  • Other new functionality to facilitate pipeline creation and editing
  • Numerous bug fixes

For more information about the new pipeline designer, see this video tutorial.

High Speed File Uploader

This release includes a new method for adding large (>2 GB) data files to the Uploads tab for users of the public GenePattern Server. It is integrated with an Aspera server to enable high speed upload of data files.  This uploader can significantly improve file transfer times.  Contact us at gp-help at broadinstitute dot org for more details.

Parallel Execution of Pipeline Steps

The pipeline engine has been updated to enable parallel execution of steps in a pipeline. This allows scatter-gather pipelines to be built with the pipeline editor and executed on the server. For best performance, these pipelines should be run on a server that is integrated with a queuing system such as LSF or SGE. For more information, contact us at gp-help at broadinstitute dot org.

GenePattern in the Cloud

This version of GenePattern has been updated to allow users to install and run their own GenePattern server in the cloud by installing the server as an Amazon Machine Instance (AMI).  For more information about how to run GenePattern in the cloud, see this article.

GenomeSpace Support

Users of GenomeSpace can send files to the cloud-based storage in GenomeSpace and use GenomeSpace files as inputs to GenePattern modules, using the new GenomeSpace tab in GenomeSpace-enabled installations of GenePattern.  GenePattern 3.4 is integrated and compatible with the public beta release of  GenomeSpace (beta 6), including GenomeSpace OpenID login, a GenomeSpace landing page within GenePattern, support for GenomeSpace file conversion, and error messages associated with GenomeSpace. For more information about GenomeSpace, see the GenomeSpace User Guide.  GenomeSpace requires Java 6.


The 3.4 release fixes issues in GenePattern, including:

  • Bug fix for the Word Add-in. The GP 3.3.3 release was incompatible with the Word Add-In client. The 3.4 release is compatible.
  • Added IGV access to data files from a GenePattern server with custom authentication.
  • Added configuration parameters for the SGE executor in the SGE plugin.
  • Links to server file paths now work when the path involves symbolic links.

Known Issues

Known issues in GenePattern 3.4 include:

  • There is a known issue regarding pipelines created in GenePattern 3.3.3 that have data files included and that have been imported to a new 3.4.0 server. If you are having problems with such a pipeline:

1. On the 3.4.0 server, select your pipeline and click edit to open it in the Pipeline Designer.
2. Click Save. You don't need to make any other changes to your pipeline.

  • There is a known issue with installing on OS X Lion (10.7) or on OS X Mountain Lion (10.8).  If you get an "Installation: Successfulnull" error or an error that looks like this:

1. Move Folder:              Destination: /Library/Frameworks/R.framework/Versions
WARNING - There was a problem copying /Library/Frameworks/R.framework/Versions/2.5

you may need to install R2.5 separately.  Download R2.5 from CRAN and follow the instruction in this section of the Administrators Guide.

  • There is a known issue with installing on OS X Mountain Lion: by default, Mountain Lion does not allow the installation of GenePattern because it is not from a "certified Apple Developer".  Workaround: Set Gatekeeper to allow applications to be installed from any source (see for more information).
  • There is a known issue with installing on OS X Mountain Lion: if you select the option to install icons in the dock during install, the icons will not appear in the dock.  They will appear when the server is running.  Workaround: You can place them in the dock manually.
  • There is a known issue with Firefox 12 in Windows: When modules are installed from the repository, the page does not update after the modules are installed. It appears as if nothing happens, but going to the Manage Modules page should show that the modules were installed.
  • There is a known issues with Internet Explorer 9: Job Results page does not refresh automatically.  Workaround: Click the "compatibility mode" icon (looks like a broken page: Picture of the Compatibility View button (off) and when you click it, it will change from an outline to a solid color: Picture of the Compatibility View button (on)) in the toolbar and the page will refresh.
  • There are known issues with Safari 5.0.5 on MacOS X. To workaround these problems, install the latest version of Safari. First try software update. If you are still at version 5.0.5 or earlier:
  • There are known issues with Internet Explorer 8 and 9: The new drag and drop functionality of both the Module Integrator and Pipeline Designer is not available to them.  Workaround: Use a different browser, such as Firefox or Chrome.
  • ComparativeMarkerSelection Version 7 may fail when run on a GenePattern server installed in C:/Program Files (x86) on a 64-bit Windows machine. Other Java modules that invoke R with the command line " -DR=..." are likely to fail as well. Workaround: Either accept the GenePattern default install location of C:\GenePatternServer or, if you want to use C:/Program Files (x86), edit the R 2.5 Home setting on the Programming Languages page to change to the default GenePattern install location (C:\Program Files (x86)\GenePatternServer).
  • GenePattern does not support module names with spaces in them.  
  • Some GenePattern modules do not work when the input filename contains a space character. Workaround: Rename the input file without a space character.
  • On Macintosh: Java Runtime Environment (JRE) 1.6.0_15 does not work. Workaround: The GenePattern team suggests updating to the most recent JRE (GenePattern 3.4 has been tested with 1.6.0_20 and above).
  • On Windows 7/Vista: The StartGenePatternServer and StopGenePatternServer applications must be run as an administrator. To start or stop the GenePattern server, right-click on StartGenePatternServer.exe or StopGenePatternServer.exe and select Run as administrator.
  • For GenePattern administrators who have changed the "input.file.mode" property (in the file) from default: GenePattern 3.4 only works with the default setting, input.file.mode=path.

Hardware Requirements and Software Compatibility

Hardware requirements: GenePattern's hardware requirements are found on almost all currently available machines:

  • 256 MB RAM (individual modules may require additional RAM depending on the data being processed)
  • 500 MHz Pentium 3 or equivalent
  • Server space: 252 MB
  • Module space: As of May 2012, installing all GenePattern modules requires approximately 1 GB of hard drive space

Supported operating systems: GenePattern installers are available for Windows, Mac OS X, and Linux. GenePattern should work with any operating system that has a Java 5 or 6 virtual machine installed. We have tested it on the following OS platforms:

  • Windows: XP (32-bit and 64-bit), Windows 7/Vista (32-bit and 64-bit)
  • Mac: OS X 10.5, 10.6, 10.7, 10.8
  • Linux: Ubuntu 10.4 & 11.10, CentOS 4 & 5 (Note: these are only the platforms we test; GenePattern works on other Linux platforms as well)

Supported browsers: GenePattern has been tested on the following browsers:

  • Internet Explorer 8 & 9 (these do not support the 3.4 Module Integrator and Pipeline Designer)
  • Firefox 11 & 12
  • Chrome
  • Safari 5.0.5 & 5.5 (5.1+ required for Module Integrator and Pipeline Designer)

Current technology versions: Following are the technology versions used in GenePattern 3.4.

  • Java 5 and/or 6
  • R 2.5.0 (Included in Windows installs. Other versions of R can easily be installed to run with GenePattern modules as needed. See FAQ 6.3 for more information.)
  • Perl 5.8.8