Argo User Guide

  1. Overview
  2. Basic Concepts
  3. Requirements
  4. Installing and Running Argo
  5. Downloading Tutorial Data
  6. Loading Data into Argo
  7. Zooming and Scrolling
  8. Setting Display Options
  9. Examining Features
  10. Analyzing Features
  11. Editing Features
  12. Comparative Perspective (Combo)

Overview

The purpose of this document is to cover the basic concepts of genome browsing and get you up and running with Argo as quickly as possible. It is a how-to, not an exhaustive reference. Though this document can stand by itself, links to more in depth treatments of particular features are provided where appropriate.

Once you are comfortable with Argo's basic operation, the best reference is the program itself; hyperlinks to specific and detailed help pages are provided from within the program's key menus and windows. All help pages, whether referenced within this document or from Argo itself, are also accessible from the main help page.

Basic Concepts: Features, Tracks, and Sequence

The data displayed by Argo is relatively simple: features on sequence. Simply put, a sequence is a string, a feature is a location on a string. Features are divided into logical and display groups called "tracks." "Annotated Transcripts" and "BlastX Hits" are examples of possible tracks. The main view in Argo, called the "Feature Map," draws features as vertically stacked arrows, with the arrow head indicating the orientation of the feature, and the color indicating the track to which the feature belongs. Tracks of features may also be segregated into distinct rows.

basic concepts

Here is non-biological analogy: sequence is like English text, say, the text of Shakespeare's Hamlet; features are like annotations or footnotes that refer to this text. Imagine you wanted to see the annotations not merely of one scholar, but of multiple or all scholars at the same time. Argo would render each scholar's annotations as distinctly colored glyphs (scholar = track, in this analogy). Overlapping annotations would be stacked vertically. It would quickly become apparent which parts of the play have attracted the most critical attention. Zooming and clicking would reveal the contents of individual annotations. Filtering and sorting would remove unwanted clutter. And if you were a scholar, you might use the program to add new annotations with reference to existing ones.

Requirements

Argo is written in java 1.4. It has been tested on Windows NT, XP, and mac OS X, but should run on any operating system that supports java 1.4. If you are not sure what version of java you are running, go to the command prompt and type java -version. If you have a version older than 1.4, or none at all, you can download it for free from http://java.sun.com/j2se/.

Mac OS 9 and earlier do not support java 1.4 and therefore cannot run Argo.

While there is no minimum memory requirement besides what is necessary to run java, the number of features and size of sequence you can look at will be constrained by the amount of available memory.

Installing and Running Argo

If you haven't already, download argo here.

The file is called argo.jar. 'argo' is a reference to the famous ship Jason used for exploration, and 'jar' stands for 'java archive.'

NOTE: Netscape 4 users will have to RIGHT CLICK and select SAVE AS in order to prevent the jar from being treated as a netscape upgrade (this won't do any harm, but it won't download the file either).

Save this file somewhere where you are likely to find it again (like your desktop). No installation is required. If java 1.4 is properly set up on your system, you should be able to just double click the jar file and it will run. It may take a few seconds to start.

You can also run it from the command line by typing:

java -jar argo.jar

from the directory in which you save it. This can be useful for debugging.

Downloading Tutorial Data

Download the tutorial files from this zip file or individually by using the links in the following table. The files are from a study characterizing cell adhesion molecules encoded by the genome of Ciona savignyi, as described here.

FileFile typeDescription
super_15687.fafasta.htmlDraft sequence from the sea squirt Ciona savignyi.
sc15687.gsGENSCANGene prediction results from GENSCAN.
sc15687.geosGenomeScanGene prediction results from GenomeScan.
geneid_15687_dm.gff1
geneid_15687_fugu.gff1
geneid_15687_iso1.gff1
geneid_15687_iso3.gff1
GENEIDGene prediction results from GENEID. Each file is the result of a GENEID run using different isochore parameters. When the results are simultaneously loaded into Argo, visual comparison of the output from each run is easy.
sc15687_huints_tbn.outtblasntblastn results where human integrins are the queries and super_15687.fa is the subject.
sc15687_otherints_tbn.outtblasntblastn results where integrins from a variety of non-mammalian species are the queries and super_15687.fa is the subject.
sc15687_v_CiESTtbx.outtlastxtblastx results where super_15687.fa is the query and the subject is several EST assemblies encoding the probable ortholog of this gene in Ciona intestinalis, a related sea squirt that is about as closely related to Ciona savignyi as human is to mouse.

Notes:

Loading Data into Argo

When you start Argo, your screen should look something like this:

blank

First, we'll load the fasta sequence from the tutorial data. Open the File Menu and choose Open Sequence File. Follow the prompts to select the super_15687.fa file and click ok. Argo prompts you to enter optional start and stop coordinates, offset, and genetic code. The defaults are fine, just click ok. The Feature Map Track Table window opens.

We'll use the Feature Map Track Table window to load the gene predictions and blast results from the tutorial data onto the sequence. Files that contain analysis results are called track files. The features (analysis results) from each file are grouped and displayed as a single track of features.

In the Feature Map Track Table window, click Load Tracks From File and follow the prompts to load the sc15687.gs file. Click OK when prompted to choose the default file format to interpret the file. The track file appears in the window. Repeat this process to load the remaining eight files. When you are finished, the window should look something like this:

track table

Click OK to close the Feature Map Track Table window. For each blast track, Argo asks if you want to "use subject coordinates" for the blast output file. If the loaded sequence was the subject of the blast, click Yes; otherwise, click No. For the tutorial data, respond as shown below:

FileUse subject coordinates?
sc15687_v_CiESTtbx.outNo
sc15687_huints_tbn.out
sc15687_otherints_tbn.out
Yes

Your Argo screen should now look something like this:

feature map colored and stranded

The main panel is called the feature map, the lower left panel is the inspector panel, and the lower right panel is the finder panel. Right click in any panel to display help for that panel.

Zooming and Scrolling

Initially, the feature map is zoomed out horizontally to show the entire sequence. It is zoomed in vertically, so you will need to scroll to see all of the features. You can scroll by using the scroll bars or by dragging the mouse while holding the alt key and the left mouse button (middle button for a 3-button mouse).

To zoom out on the vertical aspect of the feature map, select Vertical size to fit on the Zoom menu:

feature map zoomed out

To zoom back in, select Vertical restore on the Zoom menu.

The simplest way to zoom is to hold the shift key and click: left click zooms in, right click zooms out. To zoom in on an area, drag the mouse over the area while pressing the shift key and the left mouse button (middle mouse button for a 3-button mouse). Another way to zoom in on an area of interest is to select Refresh Map Data on the File menu: when Argo prompts you for the sequence range, enter start and stop values that define the portion of the sequence that you want to view. For more zoom options, see the Zoom menu.

Setting Display Options

Argo provides many display options, which you access from the Feature Map Track Table window and the Feature Map Options window. Argo automatically saves your preferences across sessions, so you don't have to remember or reset your display options when you restart Argo.

Click Track Table in the File menu to display the Feature Map Track Table window:

track table

Use this window to determine which features to display and how to display them. For example, each track of features is assigned a random color by default. To change the color, click on the colored rectangle in the color column for that track. When you have set colors for all of the tracks, click OK to redraw the feature map with your new settings. For descriptions of the many powerful and flexible display options in this window, see the track table help.

Click Feature Map Options in the File menu to display the Feature Map Options window:

map options Use this window to determine the layout of the Feature Map panel. For example, by default, the feature display options Bordered? is selected. You might choose to clear that option for a less cluttered display. To do this, click the check box next to that option, which clears the check mark, and then click OK to redraw the feature map with your new settings. For descriptions of the many powerful and flexible display options in this window, see the feature map options help.

Examining Features

Click on a feature to examine it in the Inspector window, which is in the lower left corner below the feature map.

The inspector window has four tabs. The Properties panel, which is selected by default, simply displays properties for the selected feature. The other three are sequence panels. The DNA sequence panel displays exons in blue, introns in black. The mRNA sequence panel shows the concatenated exons along with possible start and stop codons. The Protein panel shows the translation of the selected orf in the mRNA panel.

For more information, right click in any panel and select the Help option.

properties panel dna panel
mrna panel protein panel

Analyzing Features

Argo provides a number of tools to help you analyze features. As a brief example, we'll use Argo to align sequences.

If you have modified the zoom levels, return to the default view by selecting Zoom to 100% and Vertical Restore from the Zoom menu. Notice that there's a concentration of blast HSPs located roughly between 90Kb and 140Kb. The two gene predictions (the dark and light blue features) span that same area. Zoom in on the GENSCAN prediction (dark blue, sc15687.gs).

Looking at the HSPs, we expect exons 36 - 34 to be similar to exons 17 - 14. However, exon 16 doesn't appear to have a match between exons 36 and 35. To display the exon numbers, move your cursor over the exons. The following figure shows the exons of interest circled in red:

exons circled

To see if we can find a match for exon 16, we'll align sequence from that exon with the sequence for exons 36 - 34:

  1. Copy the first 30 or so bases of exon 16 to the clipboard: select exon 16, go to the DNA panel of the Inspector, select the first 30 or so bases, and press Control+C (Apple+C on Mac) to copy the sequence to the clipboard.
  2. Select the sequence for exons 36 - 34: click and drag your mouse in the ruler near the top of the Feature Map to highlight the sequence of interest. To adjust the boundaries, click on the region (Argo outlines it in blue) and drag the edges as needed.

    exons 36 to 34 selected

  3. Select Align from the Analyze menu. The Alignment window appears. The sequence in the region that you have selected in the feature map is the Target sequence. Paste the exon 16 sequence from the clipboard into the Query sequence box:

    alignment window

  4. Select the Settings tab and check that Smith-Waterman is the selected alignment method.
  5. Select the Input tab again and click Align. Argo displays the alignment results:

    alignment results

  6. Click Featurize. Argo adds the alignment feature to your Feature Map.
  7. To quickly find the new feature, use the Finder window, which is to the right of the Inspector: select the Feature tab; from the first drop-down list, select Track; from the second drop-down list, select Is; from the third drop-down list, select Dynamic Smith-Waterman; and click Search. Argo selects the features where the Track is DYNAMIC Smith-Waterman.

We can see from the alignment that an exon similar to exon 16 likely exists between exons 36 and 35:

alignment feature

To delete the selectable region you created at exons 36 - 34, select the region and press the Delete key.

Editing Features

"Featurizing" your alignment results creates a temporary (dynamic) feature. You can also use Argo to create, edit, and delete features that are stored in track files. The features must be in GTF2 or GFF3 format files and the feature tracks that you want to edit must be marked as editable in the track table. Any edits that you make are "pending," until you explicitly choose to save them or roll them back. To prevent loss of data, Argo grays out the Exit command on the File menu any time you have edits pending.

Click here for more information about creating and editing features, including a step-by-step example based on a scientific use case.

Comparative Perspective

Use the intuitive and elegant Comparative Perspective to view dot plots of multiple aligned sequences:

comparative perspective

Click here for more about the Comparative Perspective.


Last Updated: Sept 18 2006
Contact: Reinhard Engels
argo-support@broad.mit.edu